IDV Dashboard Downtime

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 18:06 UTC

Monitoring

The Identity Verification dashboard has been restored. We are closely monitoring our systems as we recover.
Posted Dec 11, 2025 - 17:30 UTC

Identified

We have identified the likely issue and are rolling out a fix.
Posted Dec 11, 2025 - 17:16 UTC

Investigating

The Identity Verification dashboard is experiencing downtime. We are investigating.
Posted Dec 11, 2025 - 16:56 UTC
This incident affected: API - Production and Dashboard.