Transactions delayed
Incident Report for Plaid
Resolved
Transactions delay is resolved.
Posted Jun 04, 2022 - 00:43 UTC
Monitoring
We are currently experiencing delays in our Transaction updates. We are expecting normal operations in approximately 5.5 hours at 00:30 UTC.
Posted Jun 03, 2022 - 19:09 UTC
This incident affected: API - Production.