Service Disruption Impacting Citi Bank connections
Resolved·Partial outage
This incident has been resolved.
Fri, Feb 7, 2025, 05:44 AM
(1 year ago)
·
Affected components
API - Production
Updates
Resolved
This incident has been resolved.
Fri, Feb 7, 2025, 05:44 AM
Investigating
We are observing issues impacting API calls and new connections to Citibank Online. We have notified Citibank Online and are working to root cause and resolve this issue as quickly as possible.