Transaction Updates Delayed

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 16:24 UTC

Update

This issue has been mitigated. We are closely monitoring our systems as we recover.
Posted Oct 21, 2025 - 09:55 UTC

Update

We're monitoring for additional health metrics to return to their baseline before re-enabling transactions updates as a means to ensure platform availability. Once our full set of internal health metrics recover we'll re-enable transactions updates.
Posted Oct 21, 2025 - 02:26 UTC

Monitoring

We have resolved the underlying issue and the system is now recovering. Transactions updates will be delayed for the next few hours.
Posted Oct 20, 2025 - 09:58 UTC
This incident affected: API - Production.