Transaction Updates Delayed

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 22:23 UTC

Update

We have resolved the underlying issue and the system is now recovering. Transactions updates will be delayed for the next few hours.
Posted Apr 23, 2026 - 17:17 UTC

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 23, 2026 - 16:33 UTC

Update

We are currently experiencing delays in our Transaction updates.
We are actively investigating and working to mitigate this issue.
Posted Apr 23, 2026 - 15:04 UTC

Identified

We are currently experiencing elevated latency for the INITIAL_UPDATE and HISTORICAL_UPDATE Transactions webhooks.
We are actively investigating and working to mitigate this issue.
Posted Apr 23, 2026 - 14:57 UTC
This incident affected: API - Production.