We identified a fix that routes around the remaining errors for Dashboard, CRA and Transfer. We've monitored those service health and see full recovery.
Posted Oct 21, 2025 - 02:22 UTC
Identified
We're seeing a low rate of lingering errors from the earlier AWS outage which is mostly contained to Dashboard, CRA and Transfer. We're continuing to investigate avenues to recover this more rapidly.
Posted Oct 20, 2025 - 22:48 UTC
Monitoring
We're observing full recovery across all endpoints and continuing to monitor.
Posted Oct 20, 2025 - 19:07 UTC
Investigating
We are continuing to experience API and Dashboard failures due to the ongoing AWS outage that are causing errors on multiple surface areas. We are investigating mitigations and waiting on further updates from AWS.
Posted Oct 20, 2025 - 17:52 UTC
This incident affected: API - Production, API - Sandbox, and Dashboard.