Service Disruption Impacting Fidelity and Fidelity NetBenefit connections

Incident Report for Plaid

Resolved

The issue affecting connections to Fidelity and Fidelity NetBenefits has been resolved. Item adds and API requests through Plaid have returned to normal operation. We will continue to monitor to ensure stability.
Posted Mar 13, 2026 - 17:37 UTC

Investigating

We are currently investigating an issue affecting connections to Fidelity and Fidelity NetBenefits. As a result, item adds and API requests for these institutions through Plaid may be impacted. Our team is actively working to resolve the issue and will share updates as they become available.
Posted Mar 13, 2026 - 16:28 UTC
This incident affected: API - Production.