Elevated dashboard error rates

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 17:41 UTC

Monitoring

The issue has been mitigated. We are closely monitoring our systems as we recover.
Posted Oct 21, 2025 - 03:40 UTC

Investigating

We are experiencing elevated error rates in the Dashboard.
We are actively investigating this issue.
Posted Oct 20, 2025 - 16:21 UTC
This incident affected: Dashboard.