Elevated dashboard error rates

Incident Report for Plaid

Monitoring

The issue has been mitigated. We are closely monitoring our systems as we recover.
Posted Mar 27, 2026 - 17:19 UTC

Investigating

We are experiencing elevated error rates in the Dashboard.
We are actively investigating this issue.
Posted Mar 27, 2026 - 17:06 UTC
This incident affects: Dashboard.