Payment Initiation API Degradation

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:56 UTC

Investigating

Investigating - The Payment Initiation API is currently experiencing a degradation, and some requests may fail with a 500 HTTP status error code. We are actively investigating and will update this incident as we have more updates.
Posted Oct 20, 2025 - 16:46 UTC
This incident affected: API - Production.