Link performance degradation
Incident Report for Plaid
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 19:55 UTC
Update
We think the impact from the issue is over.
Posted Nov 26, 2024 - 19:34 UTC
Investigating
We are experiencing degraded performance with Link. The reCAPTCHA attempts are failing. We are actively investigating and working to mitigate this issue.
Posted Nov 26, 2024 - 19:04 UTC
This incident affected: API - Production.