Elevated Item add errors

Incident Report for Plaid

Resolved

We think the impact from the issue is over.
Posted May 08, 2025 - 18:07 UTC

Monitoring

Plaid experienced elevated error rates for Item adds from 16:45 to 16:55 UTC.

We are closely monitoring our systems as we recover.
Posted May 08, 2025 - 17:03 UTC
This incident affected: API - Production.