IDV Downtime

Incident Report for Plaid

Resolved

We think the impact from the issue is over.
Posted Sep 17, 2025 - 05:46 UTC

Monitoring

A fix is deployed. We're monitoring the systems.
Posted Sep 17, 2025 - 05:41 UTC

Investigating

Identity Verification is experiencing downtime.
Posted Sep 17, 2025 - 05:23 UTC
This incident affected: API - Production.