Elevated dashboard.plaid.com error rates

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 09:54 UTC

Investigating

We are experiencing elevated error rates on dashboard.plaid.com. We are actively investigating the issue.
Posted Oct 20, 2025 - 08:03 UTC