Link performance degradation

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 17:21 UTC

Update

We're observing full recovery for the past 10 minutes. We'll continue monitoring.
Posted Oct 20, 2025 - 19:05 UTC

Monitoring

We're seeing widespread recovery of error rates related to underlying cloud infrastructure. We're continuing monitoring.
Posted Oct 20, 2025 - 18:19 UTC

Investigating

We are currently experiencing elevated error rates for Item adds. We are actively investigating and working to mitigate this issue.
Posted Oct 20, 2025 - 15:15 UTC

Monitoring

This issue has been mitigated. We are closely monitoring our systems as we recover.
Posted Oct 20, 2025 - 10:00 UTC

Investigating

We are experiencing degraded performance with Link. We are actively investigating and working to mitigate this issue.
Posted Oct 20, 2025 - 07:56 UTC
This incident affected: API - Production.