Service Disruption Impacting NFCU, Regions, US Bank, and Huntington connections

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Feb 09, 2025 - 09:26 UTC

Investigating

Several data partners are currently experiencing downtime impacting all channels and data recipients. Item adds and API calls through Plaid are impacted. We will provide an update when the issue is resolved.
Posted Feb 09, 2025 - 08:41 UTC
This incident affected: API - Production.