IDV Performance Degradation

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Dec 20, 2024 - 22:40 UTC

Monitoring

Identity Verification performance has been restored. We are closely monitoring our systems as we recover.
Posted Dec 20, 2024 - 22:23 UTC

Investigating

Identity Verification is experiencing a degradation in performance. This applies to Document checks. We are actively investigating and working to mitigate this issue.
Posted Dec 19, 2024 - 19:08 UTC