Service Disruption Impacting Citibank connections

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 07:04 UTC

Identified

Citibank is currently experiencing downtime impacting all channels and data recipients. Item adds and API calls through Plaid are impacted. We will provide an update when Citibank has resolved the issue.
Posted Jan 30, 2026 - 06:31 UTC
This incident affected: API - Production.