Transfers service experiencing failures

Incident Report for Plaid

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 20, 2025 - 05:44 UTC

Investigating

Transfer is experiencing delays impacting payment processing. This applies to Instant Payouts (RTP and FedNow).

We are actively monitoring and will update this incident as it is resolved. We will provide an update if any ACH settlement windows are missed.
Posted Jul 20, 2025 - 02:14 UTC

Identified

Transfer is experiencing delays impacting payment processing. This applies to Instant Payouts (RTP and FedNow).

We are actively monitoring and will update this incident as it is resolved. We will provide an update if any ACH settlement windows are missed.
Posted Jul 20, 2025 - 01:40 UTC
This incident affected: API - Production.