Resolved
This incident has been resolved.
Identified
We are continuing to experience increased latency of /item/public_token/exchange and /investments/transactions/get, and elevated errors for /item/remove. The root cause is an AWS outage for Kinesis APIs in the US-EAST-1 Region. AWS expects it to take 2-3 hours to recover from the outage, and we will continue to monitor until fully resolved.
Identified
In addition to increased latency of /item/public_token/exchange and /investments/transactions/get calls, requests to /item/remove are experiencing elevated error rates. We have identified the root cause of the issue and are actively working to mitigate the impact.
Identified
We have identified the root cause of the issue and are actively working to mitigate the impact.
Investigating
We are currently experiencing elevated latency in /item/public_token/exchange and /investments/transactions/get calls. We are actively investigating and working to mitigate this issue.