Elevated dashboard login error rates
Incident Report for Plaid
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 05:30 UTC
Investigating
We are experiencing elevated error rates with logging in to Dashboard. We are actively investigating this issue.
Posted Oct 25, 2023 - 05:01 UTC
This incident affected: Dashboard.