Link performance degradation

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 21:54 UTC

Investigating

We are experiencing degraded performance with Link, with around 5-10% of users experiencing this issue. We are actively investigating and working to mitigate this issue.
Posted Feb 05, 2026 - 20:54 UTC
This incident affected: API - Production.