IDV Downtime

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 17:58 UTC

Monitoring

Identity Verification experienced downtime between 17:02 to 17:07 UTC. The problem has since been identified and fixed.
Posted Apr 23, 2026 - 17:33 UTC
This incident affected: API - Production.