IDV App Degraded Performance for some customers

Incident Report for Plaid

Resolved

We've identified and resolved the issue for all clients.
Posted Jul 30, 2025 - 23:36 UTC

Investigating

The Identity Verification app is experiencing issues progressing through steps for some customers. This impacts session advancement at the start of a session
Posted Jul 30, 2025 - 23:17 UTC
This incident affected: API - Production.