Link performance degradation

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 20:08 UTC

Monitoring

This issue has been mitigated. We are closely monitoring our systems as we recover.
Posted Nov 19, 2025 - 16:35 UTC

Investigating

We are experiencing degraded performance with Link in the sandbox environment, where some customers are experiencing additional MFA prompts. We are actively investigating and working to mitigate this issue.
Posted Nov 19, 2025 - 16:23 UTC
This incident affected: API - Sandbox.