IDV Performance Degradation

Incident Report for Plaid

Resolved

Impact has been resolved.
Posted Feb 18, 2025 - 23:04 UTC

Monitoring

Identity Verification has resumed normal service. We are closely monitoring our systems as we recover.
Posted Feb 18, 2025 - 22:47 UTC

Investigating

Identity Verification is experiencing a degradation in performance. This applies to Lightning checks. We are actively investigating and working to mitigate this issue.
Posted Feb 18, 2025 - 22:22 UTC
This incident affected: API - Production.