Payment Initiation API Degradation

Incident Report for Plaid

Resolved

This incident has been resolved, Payment Initiation API is fully functional. Status updates for earlier payments affected by the incident may still be delayed and will be updated shortly.
Posted Oct 21, 2025 - 11:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 22:32 UTC

Investigating

We’re currently investigating an issue affecting the Payment Initiation API, which is experiencing degraded performance. Payment status updates may be delayed. Our team is actively working to mitigate the issue, and we’ll provide further updates as they become available.
Posted Oct 20, 2025 - 21:53 UTC
This incident affected: API - Production.