Dashboard is down

Incident Report for Plaid

Resolved

We have fixed the issue and are actively monitoring
Posted Nov 05, 2025 - 01:51 UTC

Investigating

Dashboard is down, we are investigating
Posted Nov 05, 2025 - 01:34 UTC
This incident affected: Dashboard.