Link performance degredation
Incident Report for Plaid
Resolved
This incident has been resolved.
Posted Nov 29, 2023 - 16:16 UTC
Investigating
We are investigating reported issues with Link for some customers
Posted Nov 29, 2023 - 15:50 UTC
This incident affected: API - Production.