Service Disruption Impacting Navy Federal Credit Union connections
Incident Report for Plaid
Resolved
This incident has been resolved
Posted Aug 13, 2024 - 05:22 UTC
Investigating
Navy Federal Credit Union is currently experiencing downtime impacting all channels and data recipients. Item adds and API calls through Plaid are impacted. We will provide an update when Navy Federal Credit Union has resolved the issue
Posted Aug 13, 2024 - 05:16 UTC
This incident affected: API - Production.