Elevated dashboard error rates
Incident Report for Plaid
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 18:56 UTC
Investigating
We are experiencing elevated error rates in the Dashboard for Identity Verification.
We are actively investigating this issue.
Posted Nov 19, 2024 - 18:40 UTC
This incident affected: Dashboard.