Transaction Updates Delayed

Incident Report for Plaid

Resolved

Impact for the issue is over
Posted Apr 24, 2025 - 03:57 UTC

Monitoring

We are currently experiencing delays in our Transaction updates. We have resolved the issue and are ramping updates back up linearly over the next few hours.
Posted Apr 24, 2025 - 00:28 UTC
This incident affected: API - Production.