Identity Verification downtime

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 09:55 UTC

Monitoring

The Identity Verification product experience downtime today from 08.14am UTC till 08.22am UTC. All systems are currently back operational.
Posted Jun 12, 2025 - 09:24 UTC