Signal Score Degradation

Incident Report for Plaid

Monitoring

A fix has been implemented and is deployed to production. We will continue to monitor score quality closely.
Posted Sep 02, 2025 - 23:25 UTC

Investigating

We are aware of an issue impacting the quality of Plaid Signal transaction scores, and are actively investigating.
Posted Sep 02, 2025 - 21:08 UTC
This incident affects: API - Production.