Degraded Institution Alerting

Incident Report for Plaid

Resolved

We think the impact from the issue is over.
Posted Dec 04, 2025 - 15:57 UTC

Investigating

We are currently experiencing issues with the delivery of institution status alerts. Some customers may not receive timely notifications about institution health changes.
We are actively investigating the issue.
Posted Dec 04, 2025 - 15:15 UTC
This incident affected: Dashboard.