Elevated dashboard institutions error rates

Incident Report for Plaid

Resolved

We think the impact from the issue is over.
Posted Oct 29, 2025 - 03:08 UTC

Monitoring

We have identified and mitigated the issue. We are closely monitoring our systems.
Posted Oct 28, 2025 - 18:19 UTC

Investigating

We are experiencing elevated error rates in the Dashboard for institutions features.
We are actively investigating this issue.
Posted Oct 28, 2025 - 17:03 UTC
This incident affected: Dashboard.