Link performance degradation in Sandbox

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted May 28, 2025 - 21:06 UTC

Monitoring

This issue has been mitigated. We are closely monitoring our systems as we recover.
Posted May 28, 2025 - 20:55 UTC

Identified

We are experiencing degraded performance with Link in Sandbox. This impact is limited to the Sandbox environment and is not affecting production Link. We are actively investigating and working to mitigate this issue.
Posted May 28, 2025 - 20:49 UTC
This incident affected: API - Sandbox.