Transaction Updates Delayed

Incident Report for Plaid

Resolved

Transaction update rate restored.
Posted Mar 20, 2025 - 22:52 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 20, 2025 - 16:28 UTC

Monitoring

We have resolved the underlying issue and the system is now recovering. Transactions updates will be delayed for the next few hours.
Posted Mar 20, 2025 - 15:07 UTC
This incident affected: API - Production.