Link performance degradation for Plaid Check

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 15:35 UTC

Monitoring

This issue has been mitigated. We are closely monitoring our systems as we recover.
Posted Apr 22, 2025 - 14:29 UTC

Investigating

We are experiencing degraded performance with Link for Plaid Check (Consumer Report). AT&T users are experiencing errors with SMS messages. We have identified the root cause of the issue and are actively working to mitigate the impact.
Posted Apr 22, 2025 - 14:15 UTC
This incident affected: API - Production.