Elevated Identity Verification error rates

Incident Report for Plaid

Resolved

This issue has been resolved. We will continue monitoring.
Posted Nov 12, 2025 - 16:41 UTC

Monitoring

Systems are improving. We are monitoring.
Posted Nov 12, 2025 - 16:27 UTC

Investigating

We are currently investigating the issue
Posted Nov 12, 2025 - 16:13 UTC
This incident affected: API - Production.