Identity Verification API errors

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 02:08 UTC

Update

Identity verification performance has recovered. We are monitoring our systems for any further issues.
Posted Jun 10, 2025 - 23:20 UTC

Update

The identity verification product is still degraded. Our cloud provider is testing a fix internally and seeing incremental improvements but has not published a timeline for full resolution.

End users might see a "something went wrong" screen at the SMS verification or documentary verification steps. We suggest retrying any failed interactions after a minute or two.

We will provide updates as we learn more.
Posted Jun 10, 2025 - 21:07 UTC

Update

The identity verification product is still degraded due to issues at a cloud provider. End users might see a "something went wrong" screen at the SMS verification or documentary verification steps. Our suggestion is to retry any failed interactions after about a minute.

Our provider has a permanent fix in-progress. We will provide updates as we learn more.
Posted Jun 10, 2025 - 17:12 UTC

Update

The identity verification product is still affected by issues at a cloud provider causing users to be redirected to a "something went wrong screen" at the SMS verification and documentary verification steps. Our suggestion to end users is to retry any failed interactions. We will provide updates as we learn more.
Posted Jun 10, 2025 - 13:49 UTC

Update

The identity verification product is recovering from issues at a cloud provider. We've verified that all features are working again, though our overall response time is still lower than usual. We are actively monitoring and will provide updates as we learn more.
Posted Jun 10, 2025 - 13:21 UTC

Update

The Identity Verification product continues to be degraded due to issues at a cloud provider. Documentary verifications in particular are slower than normal. Our suggestion to end users is to retry any failed interaction after a minute or two. We will provide updates as we learn more.
Posted Jun 10, 2025 - 08:32 UTC

Investigating

Identity Verification endpoints are currently experiencing unexpected intermittent downtime due to cloud provider availability issues. We are actively investigating and working to mitigate this issue.
Posted Jun 10, 2025 - 07:14 UTC
This incident affected: API - Production.