Elevated API errors on Payment Initiation API (UK & EU)

Incident Report for Plaid

Resolved

All systems are operational now.
Posted Feb 28, 2025 - 08:49 UTC

Monitoring

We've spotted that something has gone wrong. We have deployed a fix. We are currently monitoring.
Posted Feb 28, 2025 - 08:46 UTC

Investigating

The Payment Initiation API (UK & EU) is currently experiencing a degradation, and requests may fail with a 500 HTTP status error code. We are actively investigating and will update this incident as we have more updates.
Posted Feb 28, 2025 - 08:39 UTC
This incident affected: API - Production.