Link performance degradation
Incident Report for Plaid
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 22:24 UTC
Monitoring
We observed degraded performance in Link between 1:19pm and 1:31pm PST. We are actively monitoring this issue.
Posted Jan 11, 2024 - 21:55 UTC
This incident affected: API - Production.