European Payments Disruption

Incident Report for Plaid

Resolved

The incident is now resolved.
Posted Oct 14, 2025 - 21:05 UTC

Identified

We identified a disruption with our Payment Initiation products between 21:38 and 21:45 BST. The incident is now resolved.
Posted Oct 14, 2025 - 21:04 UTC