Transaction Updates Delayed

Incident Report for Plaid

Monitoring

We have resolved the underlying issue and the system is now recovering. Transactions updates will be delayed for the next few hours.
Posted Apr 01, 2026 - 06:21 UTC

Investigating

We are currently experiencing delays in our Transaction updates.
We are actively investigating and working to mitigate this issue.
Posted Apr 01, 2026 - 05:07 UTC
This incident affects: API - Production.