Link performance degradation
Incident Report for Plaid
Resolved
We have identified that this degradation was caused by a third-party provider outage. Link performance has returned back to normal levels
Posted Mar 26, 2024 - 13:41 UTC
Investigating
We are experiencing slightly degraded performance with Link. We are actively investigating and working to mitigate this issue.
Posted Mar 26, 2024 - 12:48 UTC
This incident affected: API - Production.