Elevated dashboard error rates
Incident Report for Plaid
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 21:28 UTC
Investigating
We are experiencing elevated error rates in the Dashboard. We are actively investigating and working to mitigate this issue.
Posted Jun 24, 2022 - 21:14 UTC