IDV Downtime

Incident Report for Plaid

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:14 UTC

Update

Recovery is in progress, and session success rates are improving. We are closely monitoring all systems.
Posted Oct 20, 2025 - 18:10 UTC

Update

Identity Verification is experiencing downtime.
Posted Oct 20, 2025 - 16:51 UTC

Monitoring

SMS verification is back online, we are actively monitoring all systems.
Posted Oct 20, 2025 - 12:27 UTC

Update

Identity Verification is experiencing downtime.

Risk check has fully recovered, but SMS verification is still down.
As a temporary workaround, consider temporarily disabling SMS verification on your Identity Verification template.

We will update as soon as SMS verification comes back online.
Posted Oct 20, 2025 - 10:52 UTC

Investigating

Identity Verification is experiencing downtime.

SMS verification and Risk check went down at around 6:57 AM on 10/20/2025 UTC.

Risk check is recovering but SMS verification is still down.
Posted Oct 20, 2025 - 09:51 UTC
This incident affected: API - Production.