No components marked as affected
Resolved
This incident has been resolved.
Investigating
Chase is currently experiencing downtime impacting all channels and data recipients. Item adds and/or API calls through Plaid are impacted. We will provide an update when Chase has resolved the issue.