Resolved
This incident has been resolved.
Monitoring
Recovery is in progress, and session success rates are improving. We are closely monitoring all systems.
Monitoring
Identity Verification is experiencing downtime.
Monitoring
SMS verification is back online, we are actively monitoring all systems.
Investigating
Identity Verification is experiencing downtime.
Risk check has fully recovered, but SMS verification is still down.As a temporary workaround, consider temporarily disabling SMS verification on your Identity Verification template.
We will update as soon as SMS verification comes back online.
Investigating
Identity Verification is experiencing downtime.
SMS verification and Risk check went down at around 6:57 AM on 10/20/2025 UTC.
Risk check is recovering but SMS verification is still down.